shared libraries error, Linux Mint 17

Installation, supported revisions
Post Reply
Wildkatz
Posts: 1
Joined: Thu Jun 05, 2014 6:09 pm

shared libraries error, Linux Mint 17

Post by Wildkatz » Thu Jun 05, 2014 6:16 pm

Hi,

I installed Medusa4 Personal in Linux Mint 17 successfully and also added 32-bit libraries (sudo apt-get install ia32-libs).

When I start Medusa4 the following error occurs:

/opt/medusa4_personal_v5_2_1/med2d/m2d/run/draft: error while loading shared libraries: libgomp.so.1: cannot open shared object file: No such file or directory

The missing librarie-file is placed here:
/usr/lib/x86_64-linux-gnu/libgomp.so.1

How can I link it to make the Programm run?

Thanks :)

User avatar
MikeCauser
Posts: 55
Joined: Fri Nov 16, 2012 6:04 pm
Location: Cambridge, UK

Re: shared libraries error, Linux Mint 17

Post by MikeCauser » Mon Jun 09, 2014 2:38 pm

The missing librarie-file is placed here:
/usr/lib/x86_64-linux-gnu/libgomp.so.1
That is the 64-bit version. You need to install lib32gomp1.

There may be more libraries needed too, installing Medusa on any modern Linux is always like this :-(


Mike

Thor
Posts: 1
Joined: Thu Nov 19, 2015 3:42 am

Re: shared libraries error, Linux Mint 17

Post by Thor » Thu Nov 19, 2015 4:37 am

Hey guys,
I am running into this issue too, I am not quite Linux Mint 17 fluent, what was the fix for this?
Should I be searching the repositories for this?
Thanks.

TDerksen
Posts: 28
Joined: Mon Aug 11, 2014 12:59 pm

Re: shared libraries error, Linux Mint 17

Post by TDerksen » Thu Nov 19, 2015 8:41 am

Hey,
you can fix this by installing the missing libraries, mostly common these are those libraries:
apt-get install tcsh lib32gomp1 libxtst6:i386 libxt6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libxt6:i386 libglib2.0-0:i386 libfreetype6:i386 libxrender1:i386 libfontconfig1:i386 libbz2-1.0:i386 libxml2:i386 librsvg2-2:i386

SteveIDusa
Posts: 2
Joined: Sat Dec 12, 2015 7:16 am

Re: shared libraries error, Linux Mint 17

Post by SteveIDusa » Sat Dec 12, 2015 8:18 am

Hello, I am having a similar issue with installing Medusa4 under Linux Mint 17.3, I have attempted to copy and past the suggested dependencies listed above

"sudo apt-get install tcsh lib32gomp1 libxtst6:i386 libxt6:i386 libgl1-mesa-glx:i386 libglu1-mesa:i386 libxt6:i386 libglib2.0-0:i386 libfreetype6:i386 libxrender1:i386 libfontconfig1:i386 libbz2-1.0:i386 libxml2:i386 librsvg2-2:i386"

but I get an error in the terminal as such:

"The following packages have unmet dependencies:
lib32gomp1 : Depends: gcc-4.8-base (= 4.8.2-19ubuntu1) but 4.8.4-2ubuntu1~14.04 is to be installed
libgl1-mesa-glx:i386 : Depends: libglapi-mesa:i386 (= 10.1.3-0ubuntu0.3)
E: Unable to correct problems, you have held broken packages."

I am at a loss as to what to do next, I can find this info in my package manager but do not see any other option to install any other versions.
[img]
download/file.php?mode=view&id=51[/img]

I would appreciate some assistance with the next step.
Attachments
Screen.png
Screen.png (51.39 KiB) Viewed 4568 times

SteveIDusa
Posts: 2
Joined: Sat Dec 12, 2015 7:16 am

Re: shared libraries error, Linux Mint 17

Post by SteveIDusa » Mon Dec 14, 2015 7:05 am

OK, I got it:
Did clean install of Mint 17.3 after spending a weekend mucking around with Windows 10 (Not related to Medusa).

The first attempt I installed csh, this attempt I used tcsh, then I used the above command to install the dependencies, I then ran the installer and it completed without any issues.

Launch would still crash to desktop, I used the terminal to cd to the appropriate folder and tried to launch from the terminal using ./startmedusa which opened the terminal but did not launch, but it at least displayed the missing dependency.

Used synaptic to search for and install lib32gomp.

Launched Medusa with out crash.

Post Reply