problem with licence file

Licensing and key files
GP
Posts: 2
Joined: Mon Jun 07, 2010 7:10 pm

problem with licence file

Postby GP » Mon Jun 07, 2010 6:57 pm

i have not been able to run medusa4 personal. Shows error(15) unable to optain licence on start. It then asks me to select a licence file. Its already there in install dir/medsys/med/lic and has the correct name and information. i now get error(2) invalid file path and now I have only a cancel button that closes the program.
Running windows7
Anybody got any idea what the problem and fix is

admin
Posts: 109
Joined: Tue Jul 03, 2007 10:23 am
Location: Germany
Contact:

problem with licence file

Postby admin » Mon Jun 14, 2010 9:10 am

Have you copied it over or do you let the license tool install it to the directory. Keep in mind to call the license-file csglmd.lic

GP
Posts: 2
Joined: Mon Jun 07, 2010 7:10 pm

problem with licence file

Postby GP » Sat Jun 19, 2010 12:00 am

Thanks forthe help. However CAD schroer have said there was a problem with the system issuing the licenses. I have a new license and it all works fine.

sepp2gl
Posts: 2
Joined: Tue Nov 27, 2012 5:50 pm
Location: Germany

problem with licence file

Postby sepp2gl » Tue Nov 27, 2012 6:58 pm

Got the same issue with the license file under Linux.
1. I started Medusa as "user"
Medusa asked for the lic-file and I selected it.
It didn't work

2. I copied the file, that I obtained by mail, to the directory
"/opt/medusa4_personal_v5_0/medsys/med/license" and renamed
it to csglmd.lic. This lead to a crash of the program, so I returned
to the original csglmd.lic-file.

3. I started Medusa as root using ./startmedusa in the masterproject
directory. It again asked for the license file as in 1. Now it took the
selected lic-file and copied it to csglmd.lic.
But then it crashed again with this message:
"/opt/medusa4_personal_v5_0/medcolraster/m2d/run/draft: error
while loading shared libraries: libtiff.so.3: cannot open shared
object file: No such file or directory".
So I created a link "libtiff.so.3" to the "libtiff.so.5.0.6" in "/usr/lib64".
Still it didn't work.
Now I did the same to the "libtiff.so.5" in "/usr/lib".
And now I got a similar eror message leading to the next libfile
"libbz2.so.3", which I do not have on my system.
Obviously there is something wrong with the installation script?

Is this a known issue?

kr, sepp2gl

User avatar
MikeCauser
Posts: 55
Joined: Fri Nov 16, 2012 6:04 pm
Location: Cambridge, UK

problem with licence file

Postby MikeCauser » Wed Nov 28, 2012 11:27 am

[quote author=sepp2gl link=1275929851/3#3 date=1354039116]
But then it crashed again with this message:
"/opt/medusa4_personal_v5_0/medcolraster/m2d/run/draft: error
while loading shared libraries: libtiff.so.3: cannot open shared
object file: No such file or directory".
So I created a link "libtiff.so.3" to the "libtiff.so.5.0.6" in "/usr/lib64".
Still it didn't work.
Now I did the same to the "libtiff.so.5" in "/usr/lib". [/quote]

Medusa needs a 32-bit libtiff.so.3 so copying the 64-bit libraries will not work. You need to install the 32-bit compatibility libraries and then make a link if necessary.


Mike

sepp2gl
Posts: 2
Joined: Tue Nov 27, 2012 5:50 pm
Location: Germany

problem with licence file

Postby sepp2gl » Wed Nov 28, 2012 5:36 pm

Thanks for your advice.
I already found out myself.
After I installed libbz2 on /usr/lib Medusa started OK.
So this post was not only about the lic-file but on required shared libs also.
Thanks again.
sepp2gl


Return to “Licensing”

Who is online

Users browsing this forum: No registered users and 1 guest

cron