Another error with libtiff.so.3

Installation issues
Post Reply
wphred
Posts: 2
Joined: Mon Jul 11, 2011 6:34 am
Location: Farmington Hills, Michigan

Another error with libtiff.so.3

Post by wphred » Mon Jul 11, 2011 5:56 am

I installed v5 on Ubuntu 10.04 64 bit with no problems. When I try to launch it from the Applications menu, an xterm flashes, then nothing happens.

I ran the startmedusa script in master_project and got the following error message:

medcolraster/m2d/run/draft: error while loading shared libraries: libtiff.so.3: wrong ELF class: ELFCLASS64

I saw other posts referring to 64 bit issues, but I am at a loss on what to try. Any suggestions?

wphred
Posts: 2
Joined: Mon Jul 11, 2011 6:34 am
Location: Farmington Hills, Michigan

Another error with libtiff.so.3

Post by wphred » Tue Jul 12, 2011 6:43 am

I found an answer to my problem from an older post: It came from a discussion between keeswouters and simong back in December of '09...my thanks to them.

Now I can try out the software

cd /...../medusa4/medsys/med/share/
sudo mv libtiff.so.3 libtiff.so.3.bck
ln -s -f /usr/lib32/libtiff.so.4 libtiff.so.3

back up file login in directory
..../medusa4/master_project/login --> login.bck

In this file ..../medusa4/master_project/login added the following lines:
## added to access 32bit libraries
setenv LD_LIBRARY_PATH \
`edpath -a LD_LIBRARY_PATH /usr/lib32`

(in my file just after path to '.....java/jre/lib/i386')

Then created a link for libbz2.so.1 in the /usr/lib32 directory:
cd /usr/lib32
sudo ln -s /usr/lib32/libbz2.so.1.0.4 libbz2.so.1

KiaLee
Posts: 1
Joined: Tue Apr 17, 2012 3:10 pm
Location: 423 E 82nd St, New York, NY 10

Another error with libtiff.so.3

Post by KiaLee » Tue Apr 17, 2012 2:20 pm

I never find this error. One of the more gradual changes to Ubuntu over the past two years has happened to the right-hand side of the upper panel. This is known as the panel indicator area in GNOME, or the notification area in Windows.

Post Reply