error with libtiff.so.3

Installation issues
jorgemustaine
Posts: 13
Joined: Thu May 12, 2011 8:36 pm
Location: venezuela

error with libtiff.so.3

Post by jorgemustaine » Fri May 13, 2011 2:57 pm

First of all a cordial greeting, and I downloaded the v5 MEDUSA4 to install on a system with 32bit kubuntu 11.04, and run the. sh installation without problems when trying to run the program only a black screen for a few moments and then nothing. Decided to try the console and run. / satartmedusa getting the following error:

/ opt/medusa4_personal_v5_0/medcolraster/m2d/run/draft: error while loading shared libraries: libtiff.so.3: objetc can not open shared file: No such file or directory

I first made a libtiff.so.3 locate my system and not got the file but if I have the libtiff.so4 Trying so solve the issue try creating a virtual link as follows:

ln-s / usr/lib/libtiff.so.4 libtiff.so.3

But still throws the same error probably did not know how to edit the virtual link or if there is another solution greatly appreciate your support in this regard without further reference to and is waiting soon response of you

Jorge Escalona

simong
Posts: 48
Joined: Wed Jul 04, 2007 1:14 pm

error with libtiff.so.3

Post by simong » Sat May 14, 2011 4:33 pm

Your command makes a link in the current directory which may not be in the list used for shared library searches. Try changing directory to /medsys/med/share then use the command. is the directory where you installed medusa.

jorgemustaine
Posts: 13
Joined: Thu May 12, 2011 8:36 pm
Location: venezuela

error with libtiff.so.3

Post by jorgemustaine » Mon May 16, 2011 6:15 pm

Greetings grateful for your prompt reply told him that try removing the link had been created prior to the unlink command console then try to create it with the location you described in my case will quwe

/ opt/medusa4_personal_v5_0/medsys/med/share /

and then run

sudo ln-s / usr/lib/libtiff.so.3 / usr/lib/libtiff.so4

to what linux reports a too many levels of symbolic links

well now I can not make the link

and second because in this direction if the error when running

/ opt/medusa4_personal_v5_0/master_project $ sudo. / startmedusa

is as follows

/ opt/medusa4_personal_V5_0/medcolraster/m2d/run/draft: sahra error while loading libraries: libtiff.so.3: can not open shared object file: Error 40

phil_medusa
Posts: 2
Joined: Wed May 18, 2011 3:06 pm

error with libtiff.so.3

Post by phil_medusa » Wed May 18, 2011 3:29 pm

sudo find / -name libtiff* -print

/var/lib/dpkg/info/libtiff4:i386.postinst
/var/lib/dpkg/info/libtiff4:i386.md5sums
/var/lib/dpkg/info/libtiff4:i386.shlibs
/var/lib/dpkg/info/libtiff4:i386.list
/var/lib/dpkg/info/libtiff4:i386.postrm
/usr/lib/i386-linux-gnu/libtiff.so.4.3.3
/usr/lib/i386-linux-gnu/libtiff.so.4
/usr/lib/evince/3/backends/libtiffdocument.la
/usr/lib/evince/3/backends/libtiffdocument.so
/usr/lib/evince/3/backends/libtiffdocument.a
/usr/share/doc/libtiff4
/usr/share/lintian/overrides/libtiff4


cd /usr/lib
sudo ln -nfs /usr/lib/i386-linux-gnu/libtiff.so.4.3.3 libtiff.so.3

jorgemustaine
Posts: 13
Joined: Thu May 12, 2011 8:36 pm
Location: venezuela

error with libtiff.so.3

Post by jorgemustaine » Fri May 20, 2011 8:50 pm

Congratulations you have solved my problem with the dynamic link and now I can finally start testing this promising tool for finding technological emancipation. Grateful to so useful forum and we will contact you and have a partner for it.

achu91
Posts: 4
Joined: Thu Jun 02, 2011 8:02 am
Location: India

error with libtiff.so.3

Post by achu91 » Thu Jun 02, 2011 8:46 am

i just followed the steps blindly as written in the above message ,but could not run the medusa. can any one write the steps how to install the medusa after downloading .

i googled and i found something and i have installed to /opt/medus*****.
it said installation successfull.i cannot proceed further .

pls reply i am novice user of linux.i am using ubuntu 11.04.

Achuthan

achu91
Posts: 4
Joined: Thu Jun 02, 2011 8:02 am
Location: India

error with libtiff.so.3

Post by achu91 » Thu Jun 02, 2011 10:45 am

Finally i have solved my problem.
after installation
i typed
sudo ln-s / usr/lib/******/libtiff.so.3 / usr/lib/*****/libtiff.so4

where **** is the directory name where libtiff.so.4 is present...

beezle
Posts: 1
Joined: Tue Mar 13, 2012 11:27 am

error with libtiff.so.3

Post by beezle » Tue Mar 13, 2012 11:33 am

Thx a lot twisted shrapnel!

Just installed Medusa Personal v5 on my Pinguy 11.04 Machine (more or less Ubuntu 11.04) and had the same problem.

Now it starts, thank u so much :)

Reece_Isaac
Posts: 1
Joined: Sun Oct 16, 2011 7:36 am
Location: Melbourne Australia

error with libtiff.so.3

Post by Reece_Isaac » Fri Aug 03, 2012 9:29 am

[quote author=achu91 link=1305291451/6#6 date=1307004342]Finally i have solved my problem.
after installation
i typed
sudo ln-s / usr/lib/******/libtiff.so.3 / usr/lib/*****/libtiff.so4

where **** is the directory name where libtiff.so.4 is present...

[/quote]
I found that you presented the command back to front in that the TARGET (libtiff.so.4) and the link name (libtiff.so.3) were in the wrong places. Also as I'm using Kubuntu 12.04 (64 bit) I had to create the link in the 32 (i386)bit area. Then Medusa4 started OK.

alacratstore
Posts: 2
Joined: Tue Oct 02, 2012 12:10 pm

error with libtiff.so.3

Post by alacratstore » Tue Oct 02, 2012 11:19 am

It happens with me as well and after that v5 MEDUSA4 becomes very slower as compared to the initial stage. Can you please provide the exact command and the step by step process to run it.?

Post Reply